Error: Missing Dependency: libpq.so.4 is needed by package apr-util

10 Aug

RHEL5. I had previously upgraded Postgres to 8.4.x which was in the PGDG repositories but not in the RedHat yum repositories.

Running a ‘yum update’ gave the above dependency problem.

This was fixed by:

  1. Installing the PGDG yum repositories: http://www.pgrpms.org/reporpms/repoview/letter_p.group.html
  2. Installing the compat library as per: http://www.westnet.com/~gsmith/content/postgresql/pgrpm.htm
  3. Excluding the RedHat postgresql repo -edit /etc/yum/pluginconf.g/rhnplugin.conf and add “exclude=postgresql*” to the end of it
  4. Running yum update
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: