RTNETLINK answers: Invalid argument – Static Routes

15 Nov

In Red Hat (RHEL6) you create static routes in /etc/sysconfig/network-scripts/route-eth0 or similar.

I had something like this:
GATEWAY0=192.168.1.1
NETMASK0=255.255.255.0
ADDRESS0=212.174.36.1

But it was showing the “RTNETLINK answers: Invalid argument”.

This was because the netmask was /24 but the address had the final octet in it, changing the address to 212.174.36.1 fixed it (or changing the netmask to 255.255.255.255)

Advertisements

One Response to “RTNETLINK answers: Invalid argument – Static Routes”

  1. Seanny June 8, 2012 at 7:00 pm #

    Thanks! That solved my problem!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: